Page 1 of 1

14ers.com Mobile App Issue

Posted: Wed Nov 19, 2014 9:54 am
by BillMiddlebrook
After upgrading the 14ers.com server software the other day, a software bug was created which impacts the mobile app. It caused some of the routes to be formatted incorrectly when accessed by the app, resulting in a "malformed XML" error message on the peaks page (Android app) and a few blank routes in the iOS app.

The problem has been fixed on the 14ers.com side but you may need to take action to get the mobile app working properly on your mobile device:
Android:
  • Go to All Settings on your device
  • Select Apps
  • Locate and select the 14ers.com App
  • Press the FORCE STOP (if running), CLEAR CACHE and then the CLEAR DATA buttons to clear the app data
  • Leave settings and re-open the app
Apple (iOS):
  • First, make sure you have the latest version (v1.2) of the 14ers.com mobile app. If you don't, please apply the update from the App Store/Updates page on your device.
  • If you already have v1.2, the problem should correct automatically because the routes in question have been updated and the app will get new route copies from 14ers.com
Sorry for the hassle. Post in this thread if you have problems.

Re: 14ers.com Mobile App Issue

Posted: Wed Nov 19, 2014 10:12 am
by cpb145
Thanks for the info Bill. I had noticed this issue last night. I attempted to follow the steps you outlined, but for some reason it just kept 'computing' space, and I was never able to clear the cache or stored data. I did however simply do the 'force stop', and upon reopening the app it works fine again.

Re: 14ers.com Mobile App Issue

Posted: Wed Nov 19, 2014 10:17 am
by BillMiddlebrook
I've noticed my Android device does that sometimes when trying to clear an app's data but at least we can clear data on Android.

On iOS devices, as far as I know, we have to delete and re-install the app to clear the data. That's just stupid.